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客户须知

重要：

所有文档均会过时，本文档也不例外。Microchip 的工具和文档将不断演变以满足客户的需求，因此实际使

用中有些对话框和/或工具说明可能与本文档所述之内容有所不同。请访问我们的网站

（www.microchip.com）获取最新文档。

文档均标记有“DS”编号。该编号出现在每页底部的页码之前。DS 编号的命名约定为

“DSXXXXXA_CN”，其中“XXXXX”为文档编号，“A”为文档版本。

欲了解开发工具的最新信息，请参考 MPLAB® X IDE 在线帮助。从 Help（帮助）菜单选择 Topics（主

题），打开现有在线帮助文件列表。
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1. 简介
本章包含使用 MPLAB®

集成编程环境（Integrated Programming Environment，IPE）前需要了解的一般信息。本文档

适用于随 MPLAB X IDE v5.40 或更高版本安装的 IPE 版本。

1.1 本指南使用的约定
本指南采用以下文档约定：

表 1-1. 文档约定

说明 表示 示例

Arial 字体：

斜体字 参考书目 MPLAB® IDE User's Guide

需强调的文字 ……为仅有的编译器……

首字母大写 窗口 Output 窗口

对话框 Settings 对话框

菜单选择 选择 Enable Programmer

引用 窗口或对话框中的字段名 “Save project before build”

带右尖括号且有下划线的斜体文字 菜单路径 File>Save

粗体字 对话框按钮 单击 OK

选项卡 单击 Power 选项卡

N'Rnnnn verilog 格式的数字，其中 N 为总位

数，R 为基数，n 为其中一位。

4'b0010，2'hF1

尖括号< >括起的文字 键盘上的按键 按下<Enter>，<F1>

Courier New 字体：

常规 Courier New 源代码示例 #define START

文件名 autoexec.bat

文件路径 c:\mcc18\h

关键字 _Asm，_endasm，static

命令行选项 -Opa+，-Opa-

二进制位值 0，1

常量 0xFF，‘A’

斜体 Courier New 可变参数 File.o，其中 file可以是任一有效文

件名

方括号[ ] 可选参数 mcc18 [选项] file [选项]

花括号和竖线：{ | } 选择互斥参数；“或”选择 errorlevel {0|1}
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...........（续）

说明 表示 示例

省略号... 代替重复文字 var_name [, var_name...]

表示由用户提供的代码 void main (void)
{ ...
}

1.2 推荐读物
本用户指南介绍了如何使用 Microchip MPLAB IPE。下面列出了其他有用的文档。以下 Microchip 文档均已提供，并建

议读者作为补充参考材料。

多工具设计忠告（DS51764C_CN）

请先阅读本文档！本文档包含有关在使用 MPLAB IPE 进行目标应用设计时应考虑的操作问题的重要信息。

MPLAB X IDE 在线帮助

这是在使用任何 Microchip 硬件工具时的必要参考文档。

这是 MPLAB X IDE 的扩展帮助文件，包括嵌入式系统概述、安装要求、教程、新建项目的详细信息、设置编译属性、

调试代码、设置配置位、设置断点和器件编程等。与可从 www.microchip.com/mplabx/免费下载的可打印 PDF 格式用

户指南（DS50002027E_CN）相比，本帮助文件通常可提供最新信息。

MPLAB IPE 的发行说明

有关 MPLAB IPE 的最新使用信息，请参阅 MPLAB X IDE Start（起始）页中“Release Notes and Support
Documentation”（发行说明和支持文档）下的注。发行说明包含本指南中可能没有的更新信息和已知问题。

MPLAB IPE 在线帮助文件

MPLAB IPE 的全面帮助文件包含在 MPLAB X IDE 中。与打印文档相比，本帮助文件可能包含最新信息。

处理器扩展包（PEP）和调试头规范（DS50001292W_CN）

此小册子介绍了如何安装和使用调试头。使用调试头来更好地调试所选器件，而无需占用额外的引脚和资源。另请参

见 PEP 和调试头在线帮助文件。

Transition Socket Specification（DS51194）

可参考本文档获取有关适用于调试头的转换插座的信息。

SQTP File Format Specification（DS50002539）

本文档介绍了 MPLAB® IPE 集成编程环境如何生成和使用序列号快速批量编程（Serial Quick Turn Programming，
SQTPSM）文件。工程师可使用该信息生成自己的 SQTP 文件。
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2. MPLAB IPE 概述

2.1 IPE 定义

MPLAB®
集成编程环境（IPE）是一款提供了简单界面来快速访问编程器关键功能的软件应用程序。IPE 提供适用于制

造车间的生产用户界面。

MPLAB IPE 使用 MPLAB X IDE v4.20 或更高版本框架、Microchip 调试器（Microchip Debugger，MDB）数据库、硬

件工具接口和相应的驱动程序来提供适用于所有 Microchip 编程器的编程功能。

MPLAB IPE 兼容以下所有平台：

• Microsoft Windows® 7 或更新版本

• Linux®

• macOS™

2.2 软件安装要求
必须在您的 PC 上安装 MPLAB IPE 应用程序。在 MPLAB X IDE 的安装过程中，选中相应的复选框即可安装 IPE 应用

程序（见下面的设置图）。用户无需安装 MPLAB X IDE 即可使用 IPE 应用程序。但是，用户可能需要参考 MPLAB X
IDE 的在线帮助以获取更多信息。此外，可能还需要选中希望安装的器件支持所对应的复选框。

图 2-1. Select Applications（选择应用程序）对话框

 MPLAB® IPE 用户指南
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软件安装完成后，通过桌面上或开始菜单中的 MPLAB IPE 图标即可访问 IPE 应用程序。

2.3 支持的编程工具
以下编程工具可与 IPE 配合使用：

• MPLAB ICD 3 在线调试器——建议用于生产编程

• MPLAB ICD 4 在线调试器——建议用于生产编程

• MPLAB PICkit™ 3 调试器/编程器——仅用于开发编程

• MPLAB PICkit™ 4 在线调试器——建议用于生产编程

• MPLAB Snap 在线调试器——仅用于开发编程

• MPLAB PM3 编程器——建议用于生产编程

• MPLAB REAL ICE™仿真器——建议用于生产编程

• 许可的 PKOB 入门工具包——建议仅用于开发编程

2.4 IPE 模式
IPE 应用程序有两种工作模式：

• 生产模式——您可以在该模式下执行生产编程操作。默认情况下，IPE 启动时处于生产模式。生产模式的功能通

过 Advanced Mode（高级模式）菜单来设置，此菜单将在本文档的 3.4.6  Production（生产）中讨论。

• 高级模式——提供功能丰富的 GUI 界面，您可以在该界面中查看和更改编程操作的设置，并设置适用于制造车间

的生产用户界面。要使能高级模式，请参见 3.2  设置编程器。

 MPLAB® IPE 用户指南
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3. 常规设置
本章将讨论使用 MPLAB® IPE 的入门信息。

3.1 启动 MPLAB IPE 应用程序

安装软件后，双击桌面上的 MPLAB IPE 应用程序图标。MPLAB IPE 主窗口随即打开。

图 3-1. MPLAB IPE 主窗口

IPE 的多个实例

如果您需要使用 IPE 的多个实例，请参见 MPLAB X IDE 帮助。打开 MPLAB X IDE，转到 Help>Tool Help
Contents>MPLAB X IDE Help （帮助>工具帮助内容>MPLAB X IDE 帮助），导航到“Before You Begin”（开始之

前）部分，然后导航到“Launch Multiple Instances of the IDE”（启动 IDE 的多个实例）。这些操作说明也适用于

IPE。

3.2 设置编程器

要编程器件，可以使用任意一款支持的工具（见 2.3  支持的编程工具）。有关编程器件的信息，请参见所选工具（例

如，MPLAB ICD 4 和 PICkit 4 等）的在线帮助。

1. 使用 Family（系列）下拉菜单选择您想要编程的器件系列，然后使用 Device（器件）下拉菜单选择器件。或

者，直接使用 Device 下拉菜单选择器件。

注： 从 Family 菜单中选择 Recently Used（最近使用）选项时，Device 菜单中会列出最近使用的 10 个器件。

 MPLAB® IPE 用户指南
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图 3-2. Recently Used

2. 单击 Apply（应用）将 IPE 配置为使用当前器件（例如，目标存储器视图和校验和）。

3. 将开发工具与 PC 相连，然后连接相应的目标板、器件和电源。有关连接目标板等的其他说明和相关信息，请参

见工具的在线帮助。

4. 使用 Tool（工具）下拉菜单选择要使用的工具。如果 PC 上连接有多个开发工具，请选择您要使用的那个工

具。

图 3-3. 选择工具

5. 单击 Connect（连接）按钮（在工具名称旁边），使 IPE 与工具建立连接。

6. 连接好工具后，与该工具相关的任何消息或错误都将显示在 Output（输出）窗口中（见下图）。

 MPLAB® IPE 用户指南
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图 3-4. Output 窗口

7. 成功连接工具后，继续按照下一章中的说明使用 IPE 编程器件。

3.3 高级模式登录

3.3.1 登录

通常情况下，会授权相关人员创建用于器件和工具的生产设置。要输入这些设置，需登录到高级模式。

选择 Settings>Advanced Mode（设置>高级模式），打开 Advanced Mode 登录对话框。密码区分大小写。键入默认

密码 microchip，然后单击 Login（登录）。

 MPLAB® IPE 用户指南
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图 3-5. Advanced Mode 登录

3.3.2 更改密码

首次登录后如要更改密码，请单击 Change Password（更改密码）。将打开 Change Password 对话框。

如果您忘记新密码，请单击 Log in（登录）按钮下方的 Forgot Password（忘记密码）。将打开 Forgot Password 对

话框，您可以在此对话框中回答将默认密码（microchip）更改为新密码时使用的安全问题。输入答案后，单击

Submit（提交），就会显示您的密码。

 MPLAB® IPE 用户指南
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3.3.3 保持登录

要在高级模式下无需再次输入密码直接启动 MPLAB IPE，则输入密码，选中“Keep me logged in”（保持登录）复选

框，然后单击 Log on（登录）。新安装或首次使用时将在基本模式下启动 MPLAB IPE。一旦选中“Keep me logged
in”（保持登录）复选框，以后都将在高级模式下启动 MPLAB IPE。

要取消自动在高级模式下登录，则单击 Advanced Settings（高级设置）对话框中的 Logout（注销）。

图 3-6. 取消保持登录

3.4 高级模式设置
高级模式设置必须由经过授权的相关人员操作。通过在这些对话框中选择部分设置，生产专员可从 IPE 菜单栏中的

Settings（设置）菜单查看和控制某些命令。

3.4.1 Operate
通过密码验证并登录到高级模式后，Operate（操作）视图中将打开一个对话框。此显示画面与主显示画面类似，只是

在窗口的左侧增加了选项按钮。对话框显示所选的器件和工具（见第 2.3 节“设置编程器”）。

 MPLAB® IPE 用户指南
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图 3-7. 高级模式，Operate 对话框

3.4.2 Power
Power（电源）选项仅在连接工具后可用。在 Advanced Mode 对话框中，单击 Power 可显示可用的设置。根据所选

工具和器件，仅显示适用于所选工具和器件组合的选项。

选择不同的器件系列和工具时，存储器选项会有所不同。所有设置和参数均与 MPLAB X IDE 类似。

表 3-1. 电源设置

设置 说明

注：可用选项取决于所选器件和工具。下面可能未显示所有可能的选项。

Voltage Options（电压选项）

VDD Min/Max（VDD 最小值/最大值） 该电压是供编程器用于校验存储器的电压。此值应为指定电路的最小/最大

电压。默认值为器件的最大电压值。

VDD Nom（VDD 标称值） 默认值取决于器件。例如，PIC32 的 VDD 默认标称值为 3.3V。

VPP 这是用于使器件进入编程模式的电压。尽管该电压取决于器件的编程规
范，但也可对其进行更改。

VDD App（VDD 施加值） 这是供编程器用于校验闪存的电压。默认值为器件的标称电压值。

Power Target Circuit from (tool)（通过

（工具）为目标电路供电）

该设置允许通过工具为目标电路供电。

Voltage Level（电压值） 设置想要使用的电压值。

Programming Options（编程选项）

 MPLAB® IPE 用户指南
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...........（续）

设置 说明

Programming mode entry（编程模式） 选择“Use low voltage programming mode entry”（使用低压编程模式）

或“Use high voltage programming mode entry”（使用高压编程模

式）。

Programming Method（编程方法） 选择“Apply Vdd before Vpp”（在 Vpp 之前施加 Vdd）或“Apply Vpp
before Vdd”（在 Vdd 之前施加 Vpp）。

Reset to defaults（复位为默认值） 使电压恢复为默认设置。

3.4.3 Memory
在 Advanced Mode 对话框中，单击 Memory（存储器）可显示所选器件和工具的可用设置。用户可以控制存储器地址

以及与编程操作相关的其他参数。此窗口中的部分选项也出现在主显示画面中，便于查看和快速访问这些设置。

选择不同的器件系列和工具时，存储器选项会有所不同。所有设置和参数均与 MPLAB X IDE 类似。

注： 在 v3.60 之前的 MPLAB IPE 版本中，MPLAB PM3 编程器的存储器设置可能会有所不同。

表 3-2. Memory Settings（存储器设置）

设置 说明

注：可用选项取决于所选器件和工具。下面可能未显示所有可能的选项。

Allow select memories and ranges
（允许选择存储器及范围）

选择“Allow (tool) to Select Memories”（允许（工具）选择存储器）或

“Manually select memories and ranges”（手动选择存储器及范围）。

Configuration Memory（配置存储

器）

选择该设置时，允许工具编程配置存储器。

Auxiliary Memory（辅助存储器） 选择该设置时，允许工具编程辅助存储器。

Flash Data（闪存数据） 选择该设置时，允许工具编程闪存数据。

EEPROM 选择该设置时，允许工具编程 EEPROM。

ID 选择该设置时，允许工具编程用户 ID。

Boot Flash（引导闪存） 选择该设置时，允许工具编程引导闪存。

Program Memory（程序存储器） 选择该设置时，允许工具编程程序存储器。

Program Memory Range(s)(hex)
（程序存储器范围（十六进制））

将进行编程的程序空间的地址范围（以十六进制表示）。

Preserve Program Memory（保留程

序存储器）

选择该设置时，允许工具保留程序存储器。

如果您希望使用任何保留存储器选项，首先请确保您的代码未被代码保护。对

于要保留的存储器，编程器读取需要保存的存储区域，对器件执行批量擦除，

重新编程器件，再用之前保存的内容重写保留的区域。因此，此区域不能被代

码保护。

注： MPLAB PM3 编程器在.pm3 文件类型的环境中不支持保留存储器选项。

Preserve Program Memory
Range(s)(hex)（保留程序存储器范

围（十六进制））

将保留的程序空间地址范围（以十六进制表示）。

Preserve ID Memory（保留 ID 存储

器）

选择该设置时，ID 存储器不会用 ID 存储器窗口中的任何新数据编程。仅当器

件具有用户 ID 存储器时才可使用。

注： PIC32M 器件不支持保留用户 ID 或引导存储器选项。

Reset（复位） 将地址恢复为默认设置。

 MPLAB® IPE 用户指南
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MPLAB PM3 编程器在.pm3 文件类型的环境中不支持保留存储器选项。

如果您希望使用任何保留存储器选项，首先请确保您的代码未被代码保护。对于要保留的存储器，编程器读取需要保

存的存储区域，对器件执行批量擦除，重新编程器件，再用之前保存的内容重写保留的区域。因此，此区域不能被代

码保护。

PIC32M 器件不支持保留用户 ID 或引导存储器选项。

3.4.4 Environment（环境）

环境可用于保存设置，以便能够将所有相同的设置重新加载到其他编程会话中。所有工具均支持.pen 文件或.pm3 文件

类型的环境。

注： MPLAB PM3 编程器在.pm3 文件类型的环境中不支持保留存储器选项。

在 Advanced Mode 对话框中，单击 Environment 可显示可用的设置。

表 3-3. Environment Settings（环境设置）

设置 说明

注：可用选项取决于所选器件和工具。下面可能未显示所有可能的选项。

Create Environment（创建环境）选项卡

Environment Information（环境信息）

Name（名称） 输入环境名称。

.pm3 file（.pm3 文件） 对于 MPLAB® PM3，选择此类型的文件

.pen file（.pen 文件） 对于 MPLAB ICD 3/4、PICkit 3/4 和 REAL ICE 工具，选择此类型的文件。

Description（说明） 输入环境说明。

Misc Files（其他文件） 添加或删除环境中使用的其他文件，例如，数据手册和说明等。

可以选择多个文件。

SQTP File（SQTP 文件） 浏览或输入环境中使用的 SQTP 文件名称。

Save to PM3 Card（保存到

PM3 卡）

将环境文件保存到 MPLAB PM3 SD 卡的目标位置。有关将多个操作系统固件保存

到 SD 卡的更多信息，请参见第 3.3.2 节“将固件保存至 PM3 SD 卡”。

Save to PC（保存到 PC） 将环境文件保存到 PC 上的目标位置。

Copy（复制） 打开 Copy Environment（复制环境）对话框，选择用于复制环境的源位置和目标

位置。

Browse Environments（浏览环境）选项卡

Browse on（浏览）： 选择 PC 或 MPLAB PM3 卡。

PC 如果选择了 PC，则会打开 PM3 环境文件选择浏览器，以便选择加载到 MPLAB
PM3 中的环境。

MPLAB PM3 Card（MPLAB
PM3 卡）

如果选择该选项，则会打开 PM3 卡浏览器，以便从 PM3 卡上的文件中选择环境。

在浏览器中，可以：

查看 PM3 SD 卡的属性

格式化 PM3 SD 卡

选择要加载到 MPLAB PM3 中的环境；在 Environment Settings 窗口中显示信息

选择要从 PM3 卡中删除的环境

选择环境查看信息；在 Environment Settings 窗口中显示信息

 MPLAB® IPE 用户指南
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...........（续）

设置 说明

Environment Information 显示所选环境文件的相关信息，如名称、路径和环境说明。通过此项设置，可以选

择清除信息或将环境加载到 MPLAB PM3 中。

3.4.5 SQTP
使用序列号快速批量编程（SQTP）可将惟一序列号编程到每个器件中。该序列号可用作入口密码、密码或 ID 编号。

在 Advanced Mode 对话框中，单击 SQTP 可显示可用的设置。

如果使用 MPLAB PM3 进行 SQTP 编程，则请参见下文“使用 MPLAB PM3 进行 SQTP 编程”了解更多信息。如果使

用 PIC32 器件，则请参见下文“对 PIC32 器件进行 SQTP 编程”了解有关导入方法的信息。有关如何生成 SQTP 文

件的信息，请参见 SQTP File Format Specification（DS50002539）。

表 3-4. SQTP Settings（SQTP 设置）

设置 说明

注：可用选项取决于所选器件和工具。下面可能未显示所有可能的选项。

Generation Method（生成方法）：

Random（随机） 选中此选项可为每个器件生成惟一的随机数。
另外，需在相应字段中输入起始地址、字节数以及器件数。

Pseudo Random（伪随机）

Seed Value (Hex):（种子值（十六进

制）：）

选中此选项可基于 Seed Value（种子值）字段中输入的十六进制值生成一组

不重复的伪随机数。
另外，需在相应字段中输入起始地址、字节数以及器件数。

Sequential（连续）

Start Value (Hex):（起始值（十六进

制）：）

Increment (Dec):（增量（十进

制）：）

选中此选项可基于指定的起始值和递增量生成序列号。
另外，需在相应字段中输入起始地址、字节数以及器件数。

Configuration（配置）：

Start Address (Hex):（起始地址（十

六进制）：）

输入序列号的起始地址（以十六进制表示）。

Number of bytes (Dec):（字节数（十

进制）：）

输入序列号的长度（十进制）。

确保为计划用此文件编程的器件数指定了足够长的序列号。

Number of parts (Dec):（器件数（十

进制）：）

输入要用此文件编程的器件数。

Location（位置）：

Program Memory 选中此选项可将 SQTP 编号加载到程序存储器中。

EEPROM 选中此选项可将 SQTP 编号加载到 EEPROM 中。

Auxiliary Memory 选中此选项可将 SQTP 编号加载到辅助存储器中。

User OTP Memory（用户 OTP 存储

器）

选中此选项可将 SQTP 编号加载到一次性编程存储器中。

User ID Memory（用户 ID 存储器） 选中此选项可将 SQTP 编号加载到用户 ID 存储器中。

Boot Memory（引导存储器） 选中此选项可将 SQTP 编号加载到引导存储器中。

Flash Data（闪存数据） 选中此选项可将 SQTP 编号加载到闪存中。
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...........（续）

设置 说明

Access Method（访问方法）：

RETLW 选中此选项可使用一系列 RETLW（将立即数返回到 W）指令，其中序列号

字节作为立即数。

Raw Data（原始数据） 选中此选项可使用原始数据。

Format for PSV（针对 PSV 格式化） 如果已选中 Raw Data 选项，则选中 Format for PSV 时会对 SQTP 数据进

行格式化，使其与程序空间可视性（Program Space Visibility，PSV）兼

容。

Programming Options（编程选项）：

Disable operations of SQTP values
are exhausted（SQTP 值用尽时禁止

操作）

选择此选项可在没有更多可用的 SQTP 值时停止编程。

Display the next SQTP sequence in
the output window（在 Output 窗口中

显示下一个 SQTP 序列）

选择此选项可在 Output 窗口中显示信息。

Generate（生成） 单击 Generate 可创建 SQTP（.num）文件。

使用 MPLAB PM3 进行 SQTP 编程

在 MPLAB IPE v2.20 之前为闪存数据存储器生成的 SQTP 文件将适用于版本最高为 v3.00 的 MPLAB PM3 固件。为闪

存数据存储器生成的 SQTP 文件已更改为 32 位字节序（12345678），且固件也进行了相应更新。必须重新生成新的

SQTP 文件，以便用于 MPLAB IPE v3.00 和更高版本。

对 PIC32 器件进行 SQTP 编程

仅限 PCI32 器件，从 MPLAB IPE v3.15 开始，在加载 SQTP 文件时，会出现类似于下图的对话框，用于选择 32 位字

节序（12345678）或 16 位字节序（56781234）。

图 3-8. 导入 SQTP 文件对话框

3.4.6 Production（生产）

在 Advanced Mode 对话框中，单击 Production 可显示可用的设置。

经过授权的人员可使用 Production Settings（生产设置）对话框来选择生产编程期间可用的选项。Production Settings
（见下表）中选择的选项决定 IPE 主菜单栏的 File（文件）、View（查看）和 Settings 菜单中的哪些命令在生产模式

下可用。

通过选中或取消选中各个设置为您的生产编程项目选择适当的设置。选中 Production Settings 对话框中的某个复选框

后，IPE 主菜单栏 Settings 菜单下的对应选项前面会显示一个勾号标记。

勾号标记表示已在 Advanced Mode 对话框中设置了某个选项。如果某项可用且带有勾号标记，则生产专员可通过切换

其开关状态来控制它。
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表 3-5. Production Settings

设置 说明

Allow Export Hex（允许导出十六进制

文件）

该设置允许生产专员导出十六进制文件。
选中后，该选项会显示在 File>Export （文件>导出 ）菜单下。

Allow Import Hex file（允许导入十六

进制文件）

允许生产专员导入十六进制文件。
选中后，该选项会显示在 File>Import （文件>导入 ）菜单下。

注： 如果在 IPE 中使用十六进制文件，而文件在 IPE 外使用“记事本”应

用程序 或 MPLAB X IDE 等进行了修改，则会显示一条消息：“File
modified.The loaded hex file has been modified externally.Would you like to
reload the hex file?”（文件已被修改。加载的十六进制文件已在外部被修

改。是否要重新加载十六进制文件？）。

Auto reset program stats counter（自

动复位程序统计计数器）

自动复位程序统计计数器。

Allow Import Multiple Hex file（允许导

入多个十六进制文件）

该设置允许生产专员导入多个十六进制文件。
选中后，该选项会显示在 File>Import 菜单下。

Allow Import Environment（允许导入

环境）

该设置允许生产专员导入环境。
选中后，该选项会显示在 File>Import 菜单下。

Allow Import SQTP file（允许导入

SQTP 文件）

该设置允许生产专员导入 SQTP 文件。

选中后，该选项会显示在 File>Import 菜单下。

Generate Reports（生成报告） 该设置可用于生成报告。
如果已选中 Generate Reports，则单击 Browse（浏览）可设置报告的存放

位置。

Limit the Program Count to（将编程次

数限制为）

选中后，此选项会将通过次数、失败次数和总次数限制为在相关字段中输入

的值。
这实际上会停止进一步的编程操作。

要清零主窗口中的计数，请单击 Reset Counters（复位计数器）。

Allow "Verify Device ID before
Program" under Settings menu
(Applicable only for PM3)（允许

Settings 菜单下的“Verify Device ID
before Program”（仅适用于
PM3））

该设置在 Settings 菜单中激活此选项，使生产专员能够控制此选项。

此设置仅对能够执行此功能的工具（例如，MPLAB PM3）有效。

Allow "Auto Download Firmware"
under Settings menu（允许 Settings
菜单下的“Auto Download
Firmware”）

选中后，此选项会显示在 Settings 菜单中，并且可由生产专员控制。

未选中时，IPE 会根据需要为工具自动下载最新固件。

Allow "Erase All before Program"
under Settings menu (Applicable only
for PM3 and Gen4)（允许 Settings 菜

单下的“Erase All before Program”

（仅适用于 PM3 和 Gen4））

选中后，此选项会显示在 Settings 菜单中，并且可由生产专员控制。

未选中时，生产专员无法通过 Settings 菜单控制此选项。

注： 如果连接了 PM3，该选项只能在 Settings 菜单下使能。对于所有其他

工具，该设置默认为真，且无法更改。

Allow "PM3 Communication" under
Settings menu（允许 Settings 菜单下

的“PM3 Communication”）

选中后，此选项会被使能，并且可由生产专员控制。

如果使用 MPLAB PM3 编程器 COM 端口（RS-232），则必须选中此选项才

能设置适当的 COM 端口。
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...........（续）

设置 说明

Remove Read button from main
window（从主窗口中移除 Read 按

钮）

选中此选项后，会从主窗口中移除 Read（读取）按钮。

Audible notification on successful
program completion（编程成功完成时

发出声音通知）

选中后，此选项会在编程成功完成时发出声音。

Allow memory editing and filling（允

许存储器编辑和填充）

允许编辑和填充执行存储器、配置位、用户 ID 存储器或器件 ID 存储器。

使能后，可在生产模式下通过 Window>Target Memory Views （窗口>目标

存储器视图）选项来访问此选项。

Display EEPROM checksum in the
output window（在 Output 窗口中显示

EEPROM 校验和）

选中后，EEPROM 校验和将显示在 Output 窗口中。“EEPROM 校验和”

是 MCU（如 PIC18F1220）中 EEPROM 存储器的校验和，而不是专用存储

器器件（如 11AA/LCxxx 和 24AA/LC/FCxxx）中存储器的校验和。

Display imported hex file checksum
with CP=OFF（显示 CP=OFF 的导入

十六进制文件的校验和）

选中后，不受代码保护的校验和将显示在 Results（结果）区域。

校验和是一个计算值（有关计算见器件编程规范），在执行器件读取时，该

值应与已编程器件的校验和值相匹配。选中后，CP=OFF 校验和设置将显示

代码保护位被禁止的十六进制文件的校验和。这样就可以为使能代码保护位
的十六进制映像生成有意义的校验和值。

Enable programming operations only
if hex file is loaded（仅在加载十六进

制文件时使能编程操作）

选中后，

如果未加载十六进制文件：则将禁止所有编程按钮（Program（编程）、

Read、Erase（擦除）、Verify（校验）和 Blank Check（空白检查））。

如果已加载十六进制文件，则将使能所有编程按钮。

Allow Memory View（允许存储器视图）

Program Memory 选中此选项后，程序存储器会显示在主窗口上的 Windows>Target Memory
Views（窗口>目标存储器视图）中。

Auxiliary Memory 选中此选项后，辅助存储器会显示在主窗口上的 Windows>Target Memory
Views 中。

User IDs 选中此选项后，用户 ID 会显示在主窗口上的 Windows>Target Memory
Views 中。只有工具支持用户 ID 时，此选项才适用。

Config Memory（配置存储器） 选中此选项后，配置存储器会显示在主窗口上的 Windows>Target Memory
Views 中。

Flash Data 选中此选项后，闪存会显示在主窗口上的 Windows>Target Memory Views
中。

EEPROM 选中此选项后，EEPROM 存储器会显示在主窗口上的 Windows>Target
Memory Views 中。

3.4.7 Settings
在 Advanced Mode 对话框中，单击 Settings（设置）可显示可用的选项。如果连接了 Microchip 工具，则会显示其他

选项。

表 3-6. 特殊设置

设置 说明

注：显示的选项取决于所选器件和工具。该表可能未显示所有可能的选项。

JTAG Communications method（JTAG 通信方法）
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...........（续）

设置 说明

JTAG Method（JTAG 方法） 选择 2 线 JTAG 或 4 线 JTAG。

Communication settings for AVR or SAM devices（AVR 或 SAM 器件的通信设置）

Interface（接口） 选择 JTAG 或 ISP。

Speed (MHz)（速度（MHz）） 输入适当的速度。

Programming Options（编程选项）

Program Calibration Memory（编程校准

存储区）

选择是否要编程校准存储区。

Diagnostics（诊断）

Logging Level（日志记录级别） 设置消息记录级别。
OFF（关闭）：不记录

SEVERE（严重）：仅记录严重（错误）消息。

WARNING（警告）：仅记录警告消息。

INFO（信息）：仅记录信息消息。

CONFIG（配置）：仅记录配置信息。

FINE（部分）：记录部分模块间通信。

FINER（较多）：记录更多模块间通信。

FINEST（全部）：记录所有模块间通信。

Log File（日志文件） 日志文件的路径和名称。

Tool Pack Selection（工具包选择）

Tool pack update options（工具包更新选

项）

从可用选项中选择：

使用最新安装的工具包（建议）

使用特定工具包——将打开显示可用版本的 Select Tool Pack（选择工具

包）对话框。

Specifically selected version（专门选择

的版本）

显示可用版本。

Device Pack Selection（器件包选择）

Device Packs（器件包） 当前选定器件的器件包。只有在工具断开连接的情况下，才会使能更改器

件包选择。

Special Memory Regions（特殊存储区）

Program Calibration Memory（编程校准

存储区）

允许编程用于保存器件校准值的寄存器。

Program/Read User OTP（编程/读取用

户 OTP）
允许编程或读取 OTP（一次性编程）的用户 ID 序列。一经编程，无法更

改。

Secure Segments（安全段）
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...........（续）

设置 说明

Segments to Program（要编程的段） 仅适用于带 CodeGuard™功能的器件（例如，dsPIC33FJ12GP202
等）。受 REAL ICE、MPLAB ICD 3 和 PICkit 3 支持。

选择要编程的段：

Full Chip Programming（全片编程）

Boot, Secure and General Segments（引导段、安全段和通用段）

Secure and General Segments（安全段和通用段）

General Segment Only（仅通用段）

SQTP

Disable operations if SQTP values are
exhausted（SQTP 值用尽时禁止操作）

选中此复选框会在指定.num 文件中的所有 SQTP 值用尽时禁止进一步编

程。

Display the next SQTP sequence in the
output window（在 Output 窗口中显示下

一个 SQTP 序列）

选中此复选框，在 Output 窗口中显示下一个 SQTP 序列。

Programming Method（编程方法）

您可以通过此选项为器件选择测试模式进入方法。能够为目标电路供电的工具（PM3 除外）均支持此功能。此设置

指的是编程/读取目标器件时施加 Vpp 和 Vdd 电压的顺序。

Apply Vpp before Vdd (Recommended)
（在 Vdd 之前施加 Vpp（推荐））

这是默认设置。

Apply Vdd before Vpp（在 Vpp 之前施加
Vdd）

建议使用此设置时要格外注意，因为它可能会引起不良影响。此选项仅适

用于通过调试工具为器件供电的情况。

（工具）Options（选项）

PGC Configuration（PGC 配置） 选择无、上拉或下拉。默认为下拉。

PGD resistor value (Kohms)（PGD 电阻

值（kΩ））

输入 0-50 电阻值。默认值为 4.7 kΩ。

PGC resistor value (Kohms)（PGC 电阻

值（kΩ））

输入 0-50 电阻值。默认值为 4.7 kΩ。

LED Brightness setting（LED 亮度设置） 从 1（最暗）到 10（最亮）中选择一个亮度；默认为 5。

PGD Configuration（PGD 配置） 选择无、上拉或下拉。默认为下拉。

Program Speed（编程速度） 选择 Low（低速）、Normal（正常）或 High（高速）。默认为 Normal
（正常）。

Programmer-To-Go（脱机编程）

Image Name（映像名称） 默认名称为“<your project name>_ptg”，但可以编辑名称。这是

microSDHC 卡上的文件夹名称，其中包含适用于 Programmer-To-Go 的

文件。

Send image to tool（发送映像至工具） 默认选中此复选框。选中此复选框时，会创建 PTG 映像，然后将其发送

至已连接 MPLAB PICkit 4 中的 microSDHC 卡。
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...........（续）

设置 说明

Program Device（编程器件） 默认选中此复选框。选中此复选框，将对连接至 MPLAB PICkit 4 的器件

进行编程。
注： 如果取消选中 Send image to tool 和 Program Device 这两个复选

框，则请参见“MPLAB PICkit 4 In-Circuit Debugger User's Guide”中

的“Setting Up PTG Mode Without a Memory Card”主题。

3.4.8 Logout
完成设置选择后，单击 Logout（注销）可保存设置、退出高级模式并返回主窗口。
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4. MPLAB IPE 参考

4.1 IPE 主窗口

下图给出了 IPE 的主窗口。IPE 菜单栏包含以下菜单及命令：

• File 菜单

• Settings 菜单

• View 菜单

• Tools 菜单

• Window 菜单

• Help 菜单

命令是否可用取决于几个因素，如所选的器件或高级模式下选择的设置。

图 4-1. IPE 主窗口

表 4-1. IPE 主窗口字段

项目 说明

Select Device and Tool（选择器件和工具）：

Family 按系列或最近使用的器件筛选器件。
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...........（续）

项目 说明

Device 指定器件；单击 Apply 来选择。

Tool 指定工具；酌情单击 Connect（连接）或 Disconnect（断开连接）。

Results：

CP=OFF Checksum（CP=OFF
时的校验和）

该字段仅在高级模式下使能时显示。
显示导入的十六进制文件的校验和，如同当前存储器内容对应的器件的代码保护功

能已关闭；可使用 CTRL+C 复制值。

Checksum（校验和） 当前存储器内容对应的器件的校验和值；可使用 CTRL+C 复制值

Pass Count（通过次数） 详细说明编程操作的通过次数。

Fail Count（失败次数） 详细说明编程操作的失败次数。

Total Count（总次数） 编程操作的总次数。

命令按钮：

Program 编程器件。

Erase 擦除器件。

Read 读取器件。

Verify 对器件执行校验操作。

Blank Check 检查器件是否空白。

其他：

Hex File（十六进制文件） 十六进制文件的位置，单击 Browse 以找到文件的位置。

SQTP SQTP 文件的位置，单击 Browse 以找到文件的位置。

Output 选项卡 显示输出数据。
右键单击 Output 窗口以访问其他选项。

Tool 选项卡 显示特定工具的数据，如 PM3、ICD 4 和 PICkit 4。

4.2 File 菜单

在 IPE 菜单栏中，File 菜单提供了三条命令：

• Export（导出）

• Import（导入）

• Exit（退出）

4.2.1 File>Export
您可使用 Export 菜单项将数据从 IPE 导出到存储介质。默认情况下，这些命令在生产模式下不可用。但在高级模式

下，获得授权的用户可以针对生产模式更改此功能的默认状态。

File>Export>Hex（文件>导出>十六进制）——您可以使用此命令将所有存储器内容导出为 Intel®十六进制文件格式。

4.2.2 File>Import
您可以使用 Import 菜单项将各种文件导入 IPE。默认情况下，这些命令在生产模式下不可用。但在高级模式下，获得

授权的用户可以针对生产模式更改此功能的默认状态。

• File>Import>Environment（文件>导入>环境）——选择该菜单后可导入（加载）环境（*.pen 或.pm3 文件）。
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• File>Import>Hex（文件>导入>十六进制）——选择该菜单后可导入十六进制（*.hex）文件。

注： 如果在 IPE 中使用十六进制文件，而文件在 IPE 外使用“记事本”应用程序或 MPLAB X IDE 等进行了修

改，则会显示一条消息：

• File>Import>Multiple Hex（文件>导入>多个十六进制）——选择该菜单后可导入多个十六进制文件（*.hex）。

注： 如果为 EEPROM 和闪存等各存储器生成了十六进制文件，则可将这些十六进制文件导入 MPLAB IPE。以先

进先出（fist in, first out，FIFO）的方式加载这些文件。将文件加载到 IPE 中时，文件内容将加载到所选器件的相

应存储区中。如果存储区重叠，Output 窗口中会显示一条警告消息。

在 Hex File Selection（十六进制文件选择）对话框中，单击+按钮浏览和添加文件，或单击-按钮移除文件。选择

Load（加载）导入文件。

• File>Import>SQTP（文件>导入>SQTP）——选择该菜单后可加载 SQTP 文件（*.num 文件）。

4.2.3 File>Exit
此命令用于关闭 IPE 应用程序。

4.3 Settings 菜单

4.3.1 了解 Settings 菜单命令

IPE 菜单栏上的 Settings 菜单（见下表）包含多个可供生产人员使用的命令。其中的多数命令可通过 Advanced Mode
和 Production Mode 对话框来访问。

菜单命令显示为有效状态（黑色）或不可用状态（灰显）。

带勾号标记的有效命令表示生产人员可控制这些设置。

不带勾号标记的有效命令表示只有经过授权的人员才能访问它们。

无论是否带勾号标记，不可用命令均表示生产人员无法控制这些设置。

表 4-2. Settings 菜单命令

设置 说明

Advanced Mode 此命令用于打开 Advanced Mode 登录对话框。登录通过验证后，经过授权的人员可

进行其他设置。
更多信息，请参见 3.2  设置编程器和 3.4  高级模式设置。

Verify Device ID Before
Program（编程之前校验器件
ID）

此命令仅适用于所使用器件具有器件 ID 的情况。

Erase All Before Program
（编程之前擦除全部）

此命令用于控制是否在编程器件前擦除其中的内容。
此命令不适用于可一次性编程（One-Time-Programmable，OTP）。使能“Erase All
Before Program”命令（选中复选框）时，在编程之前将擦除器件。

如果禁止此命令（取消选中），在编程之前不会擦除器件。

Auto Download Firmware
（自动下载固件）*

此命令仅适用于旧款工具（MPLAB ICD 3、PICkit 3 和 PM3）。如果选中此命令，应

用程序将验证固件是否为最新版本；必要时，将自动下载较新版本的固件。
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...........（续）

设置 说明

Manual Download Firmware
（手动下载固件）*

此命令仅适用于旧款工具（MPLAB ICD 3、PICkit 3 和 PM3），并且用于使能手动下

载固件。将打开 Firmware Browser（固件浏览器）对话框，并找到包含最新 PM3.jar
固件文件的目录。单击 Firmware File（固件文件），然后单击 OK（确定）下载固

件。

Save Firmware into SD Card
（将固件保存至 SD 卡）

此命令用于将操作系统固件下载到已插入 MPLAB PM3 编程器的 SD 卡。请参见第

3.3.2 节“将固件保存至 PM3 SD 卡”。

Hold on Reset（保持复位） 此命令用于防止编程后运行代码。

Release from Reset（从复位

释放）

此命令用于移除复位并允许代码运行。

PM3 Communication（PM3
通信）

此命令仅与 MPLAB PM3 编程器配合使用。

此命令用于打开 PM3 Communication Setting（PM3 通信设置）对话框。使用此对话

框可为 COM 端口或 USB 端口设置通信。更多信息，请参见第 3.3.3 节“PM3 通信设

置对话框”。

*单击连接/断开连接按钮或执行编程操作后，才会下载固件。

4.3.2 将固件保存至 PM3 SD 卡

在生产环境下，可能需要在不访问计算机的情况下对几个不同的器件系列架构进行编程。

在 MPLAB IPE v3.25 和 v3.40 中，PM3 操作系统根据器件架构（32 位与所有其他器件）分为两部分。在 MPLAB IPE
v3.40 中，PM3 操作系统和数据库根据 8 位、16 位和 32 位器件架构分为三部分。

MPLAB IPE v3.40 或更高版本允许用户将支持每个器件系列架构的 3 个 PM3 操作系统固件保存到 PM3 SD 卡中。

下载所有 PM3 操作系统固件之后，如果在独立模式下选择 PM3 环境，MPLAB PM3 编程器将会从 PM3 SD 卡为器件

加载正确的操作系统和数据库。

该功能仅在 MPLAB IPE v3.40 或更高版本中可用，且在 MPLAB X IDE 中不可用。

将三个操作系统全部保存到 PM3 SD 卡：

1. 将任何支持的 SD 卡插入 PM3 SD 卡槽中。

2. 打开 MPLAB IPE v3.40 或更高版本，然后将 MPLAB PM3 编程器与计算机相连。

3. 选择 Settings>Save firmware into SD Card（设置>将固件保存至 SD 卡）。当 8 位、16 位和 32 位 MCU 的操

作系统和数据库成功保存至 SD 卡时，MPLAB IPE 中的 Output 窗口会显示相关消息。

4.3.2.1 需要考虑的因素：

• 请确保 SD 卡上存储的 PM3 操作系统固件版本与 MPLAB PM3 编程器上的操作系统固件版本匹配。如果升级了

PM3 操作系统，但未更新 SD 卡固件，就可能会出现不匹配情况。使用 MPLAB IPE v3.40 或更高版本选择

Settings>Save firmware into SD Card（设置>将固件保存至 SD 卡）选项，以便将所需 PM3 操作系统固件版本加

载到 PM3 SD 卡中。

• v3.40 或更高版本的固件均不兼容 MPLAB IPE 的早期版本。强烈建议 MPLAB PM3 使用同一 MPLAB IPE 版本中

随附的固件。

版本 支持

MPLAB IPE v3.25 之前版本 支持一个操作系统。

MPLAB IPE v3.25-3.35 版本 支持两个操作系统（32 位和所有其他器件）。

MPLAB IPE v3.40 或更高版本 支持三个操作系统（8 位、16 位和 32 位器件）。
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4.3.3 PM3 Communication Setting 对话框

只有在 Advanced Mode 对话框和 Production Mode 对话框中选中 Allow "Communication" under Settings menu 对应

的复选框时，才能从 IPE 菜单栏的 Settings 菜单下访问 PM3 Communication Setting 对话框。

使用 PM3 Communication Setting 对话框前，必须用适当的电缆将 MPLAB PM3 与 PC 相连。

此对话框可用于选择 MPLAB PM3 编程器与 IPE 之间的通信端口。

要使用 MPLAB PM3 上的 RS-232 端口，请选择 COM 端口选项，然后使用下拉列表选择可用的端口。必要时，单击

刷新按钮查看可用的端口。单击 Test（测试）按钮检查 IPE 与 MPLAB PM3 之间的通信。

要将 USB 用于通信端口，请选择 USB 端口选项。

手动设置 COM 端口

在一些系统中，您可能需要手动设置通信端口。

在 Windows 系统的 Start（开始）菜单中，选择 Control Panel（控制面板），然后选择 System and Security（系统和

安全）。在 System（系统）设置中，单击 Device Manager（设备管理器）。展开 Ports（端口）下拉列表，双击要使

用的端口。单击 Port Settings（端口设置）选项卡，选择以下设置：

Bits per second（每秒位数）：57600（波特率）；Data bits（数据位）：8；Parity（奇偶校验）：None（无）；停

止位：1；Flow control（流控制）：Hardware（硬件）

单击 Advanced（高级）。取消选中 Use FIFO buffers（使用 FIFO 缓冲区）复选框。

重启 PC 以使更改生效。

4.4 View 菜单
可查看的存储器类型由高级模式下选择的生产设置决定。下面将介绍 View 菜单下的命令：

• Clear All Memory（清除所有存储器）

• 4.4.1  Memory Settings
• 4.4.2  Power Settings（电源设置）

• 4.4.3  Transfer from PM3（从 PM3 传输数据）

• 4.4.4  Transfer to PM3（向 PM3 传输数据）

• 4.4.5  Read Device ID（读取器件 ID）

• 4.4.6  View PM3 Socket Info（查看 PM3 插座信息）

Clear All Memory

清除所有存储器视图。

4.4.1 Memory Settings
显示当前存储器设置（见下方示例）。存储器设置是只读的，无法在此窗口中更改。
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图 4-2. Memory Settings 画面

4.4.2 Power Settings（电源设置）

显示当前电源设置（见下方示例）。

图 4-3. Power Settings 画面

4.4.3 Transfer from PM3（从 PM3 传输数据）

如果选择此选项，将从连接的 MPLAB PM3 编程器传输映像。状态信息显示在 Output 窗口中。

4.4.4 Transfer to PM3（向 PM3 传输数据）

如果选择此选项，将向连接的 MPLAB PM3 编程器传输映像。状态信息显示在 Output 窗口中。

4.4.5 Read Device ID（读取器件 ID）

在 Output 窗口中显示所选器件的器件 ID。

4.4.6 View PM3 Socket Info（查看 PM3 插座信息）

在 Output 窗口中显示 PM3 插座信息。
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4.5 Tools（工具）菜单
可通过 Tools 菜单访问插件。选择 Plugins（插件）以显示 Plugins Manager（插件管理器）。详细信息请参见

wiki.netbeans.org/InstallingAPlugin 中的 NetBeans 帮助主题：Managing Plugins in the IDE（管理 IDE 中的插件）。

如果安装了 MPLAB X IDE，则请参见 MPLAB X IDE 帮助文件中 Additional Tasks（额外任务）下的 Add PlugIn Tools
（添加插件工具）。

4.6 Window（窗口）菜单

4.6.1 Output
该选项在显示界面底部打开 Output 窗口。右键单击选项卡标题以显示窗口选项，如 Close（关闭）、Float（浮动）和

Move（移动）等。右键单击窗口主体以显示 Output（输出）窗口内容选项，如 Find（查找）和 Wrap text（文字换

行）等。参见下图。

图 4-4. Output 窗口右键单击菜单

4.6.2 Target Memory Views
仅在高级模式下设置了 Production Settings（生产设置），可查看不同类型的存储器时，此选项可用。其中一些存储器

视图包括执行存储器视图、配置位视图、用户 ID 存储器视图和器件 ID 存储器视图等。

4.6.3 Reset Windows（复位窗口）

选择该选项可将所有程序窗口复位为默认设置。

4.7 Help 菜单
可通过 Help 菜单访问以下在线信息：

• 自述文档——MPLAB IPE 自述文件和编程器命令行自述文件

• 帮助内容——显示所有已安装文档的合集。

• 工具帮助内容——列出了多个 Microchip 工具的帮助信息。

• 关于——显示有关当前版本 MPLAB IPE 的信息。
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5. 版本历史

5.1 版本 A（2013 年 12 月）

本文档的初始版本。

5.2 版本 B（2015 年 8 月）

修改了“软件安装要求”。IPE 现在可独立于 MPLAB X IDE 进行安装。

修改了生产模式的说明。

在常规设置章节中：

• 增加了有关新功能的信息：器件 Family 列表中的 Recently Used 选项以及创建桌面快捷方式。

• 增加了有关 Preserve Memory 选项的信息。

• 增加了有关 MPLAB PM3 编程器环境文件的注。

• 在 Allow Import Hex file（允许导入十六进制文件）选项的说明中增加了一条注。

• 增加了有关将 MPLAB PM3 编程器与 Allow "Communication" under Settings menu 选项配合使用的信息。

• 增加了 Special Memory Regions（特殊存储区）的信息。

在 MPLAB IPE 参考章节中：

• 增加了有关 File>Import>Hex（文件>导入>十六进制文件）选项的注。

5.3 版本 C（2017 年 3 月）
• 在“软件安装要求”中增加了有关 MPLAB IPE 的自述文件位置的注。

• 在“高级模式登录”一节中增加了“保持登录”主题。

• 更新了存储器范围说明。

• 更新了 Environment Settings（环境设置）选项。

• 修改了“SQTP”一节，并增加了通过 MPLAB PM3 进行 SQTP 编程以及对 PIC32 器件进行 SQTP 编程的章节。

• 增加了新的 SQTP 设置。

• 更新了 IPE 主窗口的字段说明。

• 在 View 菜单中增加了 Read Device ID（读取器件 ID）新选项。

• 增加了将固件保存至 SD 卡中的新设置菜单命令，并增加了“Save Firmware into PM3 SD Card”（将固件保存

至 SD 卡）的修订信息。

5.4 版本 D（2018 年 6 月）
• 在前言中，增加了兼容性的注，用于反映自 MPLAB X IDE v4.20 或更高版本开始进行的更改。

• 通篇进行了多处更新，以反映对 NetBeans 平台程序进行的更改。增加了 Tools 和 Window 菜单，更新了图形、

文本和菜单选项。

5.5 版本 E（2020 年 4 月）
• 对整个文档新进行了格式和编号调整。

• 在前言中，增加了兼容性的注，用于反映自 MPLAB X IDE v5.40 或更高版本开始进行的更改。

• 更换了“软件安装要求”一节中的 Select Apllications（选择应用程序）对话框界面。

• 删除了“功能矩阵”一节。
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• 在“启动 MPLAB IPE 应用程序”一节中，增加了“IPE 的多个实例”新标题。

• 更换了高级模式登录界面，并增加了 Change Password 对话框和 Forgot Password 对话框界面。

• 更新了 Production Settings 表。

• 更新了特殊设置表，增加了工具和器件包以及其他选项（包括 Programmer-To-Go 和 JTAG 等）的信息。同时删

除了 PM3 编程速度选项和界面。

 MPLAB® IPE 用户指南
版本历史

© 2018-2020 Microchip Technology Inc.  用户指南 DS50002227E_CN-第 31 页



6. 支持
有关支持问题，请参见此处讨论的各项。

• 6.1  保修登记

• 6.2  Microchip 网站

• 6.3  个性化通知客户服务

• 6.4  客户支持

6.1 保修登记

如果您的开发工具包中包含保修登记卡，请填写该保修登记卡并尽快寄出。寄出保修登记卡的客户可收到新产品更新

信息。可在 Microchip 网站上获得临时软件版本。

6.2 Microchip 网站

Microchip 网站（www.microchip.com）为客户提供在线支持。客户可通过该网站方便地获取文件和信息。只要使用常

用的互联网浏览器即可访问，网站提供以下信息：

• 产品支持——数据手册和勘误表、应用笔记和示例程序、设计资源、用户指南以及硬件支持文档、最新的软件版
本以及归档软件

• 一般技术支持——常见问题（Frequently Asked Questions，FAQ）、技术支持请求、在线讨论组以及 Microchip
顾问计划成员名单

• Microchip 业务——产品选型和订购指南、最新 Microchip 新闻稿、研讨会和活动安排表、Microchip 销售办事

处、代理商以及工厂代表列表

6.3 个性化通知客户服务

Microchip 的个人通知客户服务有助于客户了解关于所关注 Microchip 产品的最新信息。注册客户可在指定产品系列或

开发工具发生变更、更新、发布新版本或勘误表时，收到电子邮件通知。

请访问 http://www.microchip.com/pcn 开始注册过程，并选择接收个性化通知的首选项。页面上提供了 FAQ 和注册详

细信息，可以通过选择上面的链接打开。

在选择首选项时，选择“Development Systems”（开发系统）将会在列表中填入可用的开发工具。下面列出了主要

的工具类别：

• 编译器——Microchip C 编译器、汇编器、链接器及其他语言工具的最新信息。包括所有 MPLAB C 编译器、所有

MPLAB 汇编器（包括 MPASM™汇编器）、所有 MPLAB 链接器（包括 MPLINK™目标链接器），以及所有

MPLAB 库管理器（包括 MPLIB™目标库管理器）。

• 仿真器——Microchip 在线仿真器的最新信息，包括 MPLAB REAL ICE 在线仿真器。

• 在线调试器——Microchip 在线调试器的最新信息。其中包括 MPLAB ICD 3 和 MPLAB ICD 4 在线调试器以及

PICkit™ 3 和 MPLAB PICkit 4 在线调试器。

• MPLAB® X IDE——关于开发系统工具的多平台（Windows®、macOS™和 Linux®）集成开发环境 Microchip
MPLAB X IDE 的最新信息。

• 编程器——Microchip 编程器的最新信息。其中包括器件（生产）编程器（如 MPLAB REAL ICE 在线仿真器）、

MPLAB ICD 4 在线调试器、MPLAB PICkit 4 在线调试器、MPLAB PM3 以及开发（非生产）编程器和 PICkit 3。
• 入门/演示板——包括 MPLAB 入门工具包电路板、PICDEM™演示板以及各种其他评估板。

6.4 客户支持

Microchip 产品的用户可通过以下渠道获得帮助：
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• 代理商或代表

• 当地销售办事处

• 应用工程师（ESE）
• 技术支持

客户应联系其代理商、代表或应用工程师（ESE）寻求支持。当地销售办事处也可为客户提供帮助。本文档后附有销

售办事处的联系方式。欲获得最新、最全的销售办事处列表，请访问我们的网站。

也可通过 http://support.microchip.com 获得网上技术支持。

如果您发现本文档有任何错误或者对本文档有任何建议，请通过电子邮件联系我公司 TRC 经理，电子邮件地址为

CTRC@microchip.com。
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Microchip 网站

Microchip 网站（www.microchip.com/）为客户提供在线支持。客户可通过该网站方便地获取文件和信息。我们的网站

提供以下内容：

• 产品支持——数据手册和勘误表、应用笔记和示例程序、设计资源、用户指南以及硬件支持文档、最新的软件版
本以及归档软件

• 一般技术支持——常见问题解答（FAQ）、技术支持请求、在线讨论组以及 Microchip 设计伙伴计划成员名单

• Microchip 业务——产品选型和订购指南、最新 Microchip 新闻稿、研讨会和活动安排表、Microchip 销售办事

处、代理商以及工厂代表列表

产品变更通知服务

Microchip 的产品变更通知服务有助于客户了解 Microchip 产品的最新信息。注册客户可在他们感兴趣的某个产品系列

或开发工具发生变更、更新、发布新版本或勘误表时，收到电子邮件通知。

欲注册，请访问 www.microchip.com/pcn，然后按照注册说明进行操作。

客户支持

Microchip 产品的用户可通过以下渠道获得帮助：

• 代理商或代表

• 当地销售办事处

• 应用工程师（ESE）
• 技术支持

客户应联系其代理商、代表或 ESE 寻求支持。当地销售办事处也可为客户提供帮助。本文档后附有销售办事处的联系

方式。

也可通过 www.microchip.com/support 获得网上技术支持。

Microchip 器件代码保护功能

请注意以下有关 Microchip 器件代码保护功能的要点：

• Microchip 的产品均达到 Microchip 数据手册中所述的技术规范。

• Microchip 确信：在正常使用的情况下，Microchip 系列产品非常安全。

• 目前，仍存在着用恶意、甚至是非法的方法来试图破坏代码保护功能的行为。我们确信，所有这些行为都不是以

Microchip 数据手册中规定的操作规范来使用 Microchip 产品的。这种试图破坏代码保护功能的行为极可能侵犯

Microchip 的知识产权。

• Microchip 愿与那些注重代码完整性的客户合作。

• Microchip 或任何其他半导体厂商均无法保证其代码的安全性。代码保护并不意味着我们保证产品是“牢不可破”

的。代码保护功能处于持续发展中。Microchip 承诺将不断改进产品的代码保护功能。任何试图破坏 Microchip 代

码保护功能的行为均可视为违反了《数字器件千年版权法案（Digital Millennium Copyright Act）》。如果这种行

为导致他人在未经授权的情况下，能访问您的软件或其他受版权保护的成果，您有权依据该法案提起诉讼，从而

制止这种行为。

法律声明

提供本文档的中文版本仅为了便于理解。请勿忽视文档中包含的英文部分，因为其中提供了有关 Microchip 产品性能和

使用情况的有用信息。Microchip Technology Inc.及其分公司和相关公司、各级主管与员工及事务代理机构对译文中可

能存在的任何差错不承担任何责任。建议参考 Microchip Technology Inc.的英文原版文档。
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本出版物中提供的信息仅仅是为方便您使用 Microchip 产品或使用这些产品来进行设计。本出版物中所述的器件应用信

息及其他类似内容仅为您提供便利，它们可能由更新之信息所替代。确保应用符合技术规范，是您自身应负的责任。

MICROCHIP“按原样”提供这些信息。Microchip 对这些信息不作任何明示或暗示、书面或口头、法定或其他形式的

声明或担保，包括但不限于针对非侵权性、适销性和特定用途的适用性的暗示担保，或针对其使用情况、质量或性能

的担保。

在任何情况下，对于因这些信息或使用这些信息而产生的任何间接的、特殊的、惩罚性的、偶然的或间接的损失、损

害或任何类型的开销，MICROCHIP 概不承担任何责任，即使 MICROCHIP 已被告知可能发生损害或损害可以预见。

在法律允许的最大范围内，对于因这些信息或使用这些信息而产生的所有索赔，MICROCHIP 在任何情况下所承担的

全部责任均不超出您为获得这些信息向 MICROCHIP 直接支付的金额（如有）。如果将 Microchip 器件用于生命维持

和/或生命安全应用，一切风险由买方自负。买方同意在由此引发任何一切损害、索赔、诉讼或费用时，会维护和保障

Microchip 免于承担法律责任。除非另外声明，在 Microchip 知识产权保护下，不得暗中或以其他方式转让任何许可

证。

商标

Microchip 的名称和徽标组合、Microchip 徽标、Adaptec、AnyRate、AVR、AVR 徽标、AVR Freaks、BesTime、
BitCloud、chipKIT、chipKIT 徽标、CryptoMemory、CryptoRF、dsPIC、FlashFlex、flexPWR、HELDO、IGLOO、

JukeBlox、KeeLoq、Kleer、LANCheck、LinkMD、maXStylus、maXTouch、MediaLB、megaAVR、Microsemi、
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SQTP 为 Microchip Technology Incorporated 在美国的服务标记。

Adaptec 徽标、Frequency on Demand、Silicon Storage Technology 和 Symmcom 均为 Microchip Technology Inc.在
除美国外的国家或地区的注册商标。

GestIC 为 Microchip Technology Inc.的子公司 Microchip Technology Germany II GmbH & Co. KG 在除美国外的国家

或地区的注册商标。

在此提及的所有其他商标均为各持有公司所有。

© 2020，Microchip Technology Incorporated 版权所有。
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质量管理体系

有关 Microchip 的质量管理体系的信息，请访问 www.microchip.com/quality。
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